I was getting an error when trying to load the install screen. The version is zenario-probusiness-7.7.43763

The error message: ...public_html/cms/.htaccess: Invalid command 'php_flag', perhaps misspelled or defined by a module not included in the server configuration

So, I commented out the setting in .htaccess as follows: 

<IfModule mod_deflate.c>
#SetOutputFilter DEFLATE
AddOutputFilterByType DEFLATE text/css text/csv text/html text/plain text/xml text/javascript application/javascript application/x-javascript
# php_flag zlib.output_compression Off
</IfModule>

Now it loads, but I am unable to continue beyond the welcome screen with message: 

Unable to start a session! ...

  • Check the COOKIE_DOMAIN setting in the zenario_siteconfig.php file to ensure it is not referencing a different domain.
  • Check for any problems with caching or session storage on the server.

My config file is still empty pre-install. Can someone please advise? Thank you!

Fixed...

It seems that using Safari was the issue - at least I hope. I was able to complete the install from the Chrome browser. Please inform me of any known issues regarding the php_flag usage or settings.

Thanks

Hi there, thanks for reporting these problems!

 

The error message about the php_flag command was most likely because the modphp module is not enabled in your Apache config. In future builds of the CMS we'll add a check for this.

 

The bug with Safari should also be fixed in the next build.

Hi,

 

Got errors when installing recent zenario version, the only that works is 7.5.40675, but the newer versions doesn't work.

 

Symptom : blank page when going to installation directory.

Apache error : HP Parse error:  syntax error, unexpected '?' in /var/www/html/sites/zenario-probusiness-8.0/zenario/index.php on line 123

 

note : every version with this line doesn't seem to work at all :  "$status = ze\content::getShowableContent($content, $version, $cID, $cType, ($_REQUEST['cVersion'] ?? false), $checkRequestVars = true);"

 

I can install successfully the version 7.5.40675, it only tells me that friendly url are not supported.

 

I tested the trick here with no success : https://zenar.io/installing-updating-thread?forum_thread=99

 

Does anyone have an idea ?

 

Thanks

 

 

i think i got it : i need php version 7 ! i only have version 5.6...

Hi there!

 

Yes, sorry, if you're still running php 5 then you're limited to Zenario version 7.5 or earlier.

 

PHP 7 has some new features that we've started to use, plus it runs a lot faster, so I would recommend updating if you can.

You must confirm your screen name on your profile in order to comment.

Please Login if you wish to add a comment.