I was getting an error when trying to load the install screen. The version is zenario-probusiness-7.7.43763

The error message: ...public_html/cms/.htaccess: Invalid command 'php_flag', perhaps misspelled or defined by a module not included in the server configuration

So, I commented out the setting in .htaccess as follows: 

<IfModule mod_deflate.c>
#SetOutputFilter DEFLATE
AddOutputFilterByType DEFLATE text/css text/csv text/html text/plain text/xml text/javascript application/javascript application/x-javascript
# php_flag zlib.output_compression Off

Now it loads, but I am unable to continue beyond the welcome screen with message: 

Unable to start a session! ...

  • Check the COOKIE_DOMAIN setting in the zenario_siteconfig.php file to ensure it is not referencing a different domain.
  • Check for any problems with caching or session storage on the server.

My config file is still empty pre-install. Can someone please advise? Thank you!


It seems that using Safari was the issue - at least I hope. I was able to complete the install from the Chrome browser. Please inform me of any known issues regarding the php_flag usage or settings.


Hi there, thanks for reporting these problems!


The error message about the php_flag command was most likely because the modphp module is not enabled in your Apache config. In future builds of the CMS we'll add a check for this.


The bug with Safari should also be fixed in the next build.



Got errors when installing recent zenario version, the only that works is 7.5.40675, but the newer versions doesn't work.


Symptom : blank page when going to installation directory.

Apache error : HP Parse error:  syntax error, unexpected '?' in /var/www/html/sites/zenario-probusiness-8.0/zenario/index.php on line 123


note : every version with this line doesn't seem to work at all :  "$status = ze\content::getShowableContent($content, $version, $cID, $cType, ($_REQUEST['cVersion'] ?? false), $checkRequestVars = true);"


I can install successfully the version 7.5.40675, it only tells me that friendly url are not supported.


I tested the trick here with no success : https://zenar.io/installing-updating-thread?forum_thread=99


Does anyone have an idea ?





i think i got it : i need php version 7 ! i only have version 5.6...

Hi there!


Yes, sorry, if you're still running php 5 then you're limited to Zenario version 7.5 or earlier.


PHP 7 has some new features that we've started to use, plus it runs a lot faster, so I would recommend updating if you can.

Hi Chris, a few more problems today. I'm trying to upgrade from 8.9 to 9.3 but using a different subfolder for testing first. The fresh install worked well and then the database backup loaded fine. But it will not upgrade the database for me to match the installation. Here is part of the error code it sent as an email... accessing /zenario9-3/zenario/admin/welcome.ajax.php?task=&get=%5B%5D

Database query error
Specified key was too long; max key length is 1000 bytes
ALTER TABLE `z_admin_setting_defaults` MODIFY COLUMN
  `name` varchar(255)  NOT NULL DEFAULT ''

I modified the key length in the database and still no success! Any ideas?

Ok, I was able to load and update the database from version 8.9 to version 9.0 and got the layouts working after clearing the cache. There is an issue with the CRM integration that I started to have before the upgrade and it still won't work here...

Error reads: Database query error: 2006, MySQL server has gone away, SELECT local_text, seen_in_visitor_mode, seen_at_url IS NULL FROM...

Any ideas?

Hi Paul,

When moving from Zenario 8 to 9, the layouts are moved to the database, and no longer in the file system. They will be left there (in zenario_custom/templates/grid_templates) but will no longer be used, so they can be deleted.

Similarly, the skins directory is now expected to be directly inside zenario_custom. You will need to move that manually.

Please see https://zenar.io/zenario-9/zenario-90 for more details.

Hey there!

Can I ask a couple of questions about your "MySQL server has gone away" errors?

Firstly, are they appearing randomly with no pattern, or do they always happen when you try to do a specific thing?

Secondly, have you tried restarting MySQL, and did that stop you seeing the errors again?


The reason I ask is that I've seen this error before on a random dev site, but it turned out to be nothing to do with Zenario, it was just an issue with MySQL's services that vanished when I restarted them.

I've no idea if that's any relation to your problem here, but I think that would be my initial step to try just to rule it out first!


Assuming that didn't fix it and you still have an issue, is it possible that you could tell us the exact steps you took to reproduce it?


You must confirm your screen name on your profile in order to comment.

Please Login if you wish to add a comment.