Thursday 4th January 2018 14:54

I am trying to install 7.7.43763 on a Hostgator shared server.  After unzipping the files into a directory, I tried to access the directory from a browser and got the following messages:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@igc.hk and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

 

I put a file with a simple phpinfo() in the directory and tried to access that file and got the same message.  But when I deleted all the Zenario files from the directory, phpinfo works fine.  

 

Thank you for your help.

Thursday 4th January 2018 15:03

It would be helpful if you are able to see in your Apache error log what the error was. 

 

It is sometimes in /var/log/apache/sitename.error (it will be defined in your Apache virtual host file, which is possibly in /etc/apache/sites-enabled for example).

 

The line in the error log should explain. It could be as simple as an error in the .htaccess file.

Thursday 4th January 2018 15:06

The problem seems to come from the .htaccess file that comes with Zenario 7.7.  If I just have the .htaccess file from the 7.7 distribution and phpinfo in the directory, I get the same error.  But when I copied one from a previous version (7.1.3), the phpinfo works.  

Thursday 4th January 2018 15:19

But replacing the 7.7 .htaccess with the 7.1.3 .htaccess does not work.  I got a different error message saying that the server is unable to handle the request HTTP error 500. 

 

The error log has the following entry : "first argument must be 'add', 'set', 'append', 'merge', 'unset', 'echo', 'edit', or 'edit*' when I am using the .htaccess from the 7.7 distribution.

Thursday 4th January 2018 15:20

You must use the new (7.7) .htaccess file in order for Zenario to work. 

 

Can you please post the error from the log?

Thursday 4th January 2018 15:29

I used http://www.htaccesscheck.com to check the .htaccess file and the error seems to be this one :

 

3  <ifModule mod_headers.c>
4 Header setifempty X-Frame-Options SAMEORIGIN
5 </ifModule>

Thursday 4th January 2018 15:30

Hi kcpau

 

This looks like the same problem as in this thread from last month.

 

Zenario 7.7 needs Apache Server version 2.4.7 or later. You either need to update your copy of Apache, or else you'll need to edit the .htaccess file as a workaround (you can check the thread I linked to see the edit you need to make).

Thursday 4th January 2018 15:41

Chris, I made the change but now I get a different error:

This page isn’t working

igc.hk is currently unable to handle this request.

HTTP ERROR 500    
Thursday 4th January 2018 16:09

I have looked at several web hosting companies and have been having problem finding one that support PHP7, MySQL 5.5.3 and Apache 2.4.7.  I may have to stay with earlier releases for now.

Thursday 4th January 2018 16:56

Hi kcpau,

 

I would be interested to hear which (if any) of these packages is the problem. Is PHP7 too new?

 

We usually recommend having a virtual server, because you can then be sure that MySQL is well configured. If you use shared hosting for a large site (not just Zenario, but any CMS) there is a chance things like the query cache are not enabled (which they can't do effectively across multiple sites), and so sites run slowly.

 

For maybe $10 a month you could get a virtual server. If you use AWS, which we do for some of our servers, this works very nicely too. 

 

We could set up an AWS server for you from a Zenario-ready image. Please contact me if that would interesting (we'd need to charge for doing the setup).

You must confirm your screen name on your profile in order to comment.

Please Login if you wish to add a message.