Friday 5th January 2018 13:46

I have a site working on one shared server company and tried to move it to a shared server in another company.  But after the move all the uploaded files cannot be accessed.  The error message when I clicked on the link is that I do not have permission to access the file.

 

The error log shows that "Symbolic link not allowed or link target not accessible".  I noticed that for every file uploaded, there is an symbolic link entry in the public/downloads directory which links to a file in docstore.  I searched on line and it seems that one possible problem is that Apache was running under a different username than the file owner.  But I checked with the hosting company and they said that Apache is running under the same username as the file owner so that is not a problem.

 

If I upload a file in the new site, the file is accessible but it is stored in the private directory.  There are many files uploaded and I don't want to reload all the files.  Any suggestions will be most appreciated.

Saturday 6th January 2018 03:56

Problem solved.  It seems that after the move the symbolic links were still pointing to the old server.  So I wrote a simple PHP program to change all the links.

You must confirm your screen name on your profile in order to comment.

Please Login if you wish to add a message.