Sunday 6th August 2017 17:41

Hello everybody,

When migrating to version: 7.6.41633, I first unpacked the files locally, uploaded to the main directory ( and tried to start the installation. When I visited the website I received the following message:

- 500 internal server error

After replacing the .htaccess from the version zenario-probusiness-,
I could easily install Zenario. I am using PHP 7.1.

Maybe the structure of the .htaccess is inconform?

How can this be solved?

Monday 7th August 2017 09:34

Hi there TEC


Whenever you see the message 500 internal server error, this basically just means that there is an error message but your config on your server is hiding it from you.


This can be a useful feature - e.g. you might not want to show a visitor to your site the exact details of an error - however debugging very hard without the actual error message.


Could we get you to find out what the actual error message was? You can do this either by checking your error log, or by enabling the "show errors" option in your apache config.




The best guess I can come up with without actually knowing what the error message was is that you may have the AddType directive disabled in your .htaccess files. You could probably fix the problem by either enabling the directive.


If this is not possible, you could edit your .htaccess file and delete the following line


AddType application/font-woff .woff


This is probably the one causing the error, and is non-essential.

Saturday 7th October 2017 02:39

I have the same problem when I tried 7.7.  The message in the error log is :

[Sat Oct 07 09:33:49.773854 2017] [core:alert] [pid 14004:tid 1972] [client ::1:62037] C:/xampp-portable/htdocs/zen/.htaccess: first argument must be 'add', 'set', 'append', 'merge', 'unset', 'echo', 'edit', or 'edit*'.


Making the change you suggested above did not help.  

Saturday 7th October 2017 03:21

I replace the .htaccess file in 7.7 with one from a previous 7.1 version, and now it gets past the server error.  But now it has a syntax error of unexpected '?'.  The problem line is 118 in zenario/index.php which is :


$status = getShowableContent($content, $version, $cID, $cType, ($_REQUEST['cVersion'] ?? false), $checkRequestVars = true);


You help is much appreciated.


Update : i just checked to see that 7.7 requires PHP 7.  So this is not a bug.  


Sunday 8th October 2017 18:50

Indeed, I'm afraid you need PHP7. Sorry if it's a trouble to upgrade your server, but I think it's worth it. We find sites run at least 50% faster than on PHP5 (not scientifically measured... but it's a significant speed-up).

You must confirm your screen name on your profile in order to comment.

Please Login if you wish to add a message.